News

Feb 21st UPDATE WORDPRESS

If you are still using WordPress version less than 4.7.2, then update immediately. There's a severe WordPress security vulnerability found by Sucuri (and fixed in WP 4.7.2 version). More details here and here.If Wordpress is not updated we will do so and will not be held responsible for any issues to your site caused by the update. Read More »

Jan 20th ROSCOE - Server Issues

Greetings!We're investigatng isues on server Roscoe now and will update this post as soon as we have more details or theissue is resolved.The GeekGhost Admin TeamUpdate 01:16 PM EST : Roscoe was reboted and sites are currently loading. We're still looking a the cause of the issue.Update 01:38 PM EST : The cause of the creash was found and Roscoe ... Read More »

Powered by WHMCompleteSolution